Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GEOS-InfoBase-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

1

Sonntag, 14. Januar 2018, 21:39

Fehler Meldungen von Geos 2.01

Hallo Leute
gibt es eine Liste der Fehler Meldungen von Geoworks und wie man sie behebt?
Gruß Uwe

2

Sonntag, 14. Januar 2018, 22:40

Hier ist die Liste von NDO. Sie ist praktisch identisch zur Liste für 2.01: http://geos-infobase.de/ND_DOCS/INDEX.HTM#Error
d[ 0_O ]b

3

Sonntag, 14. Januar 2018, 22:44

Im Geos-Heimwerker standen ähnliche Listen. Die Online-Version findest Du hier:
http://geos-printarchiv.de/archive/dgh/ausgabe-21
Die originale GeoWrite-Version solltest Du auch auf der Infobase oder auf gopa finden...
d[ 0_O ]b

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

4

Sonntag, 14. Januar 2018, 23:09

Ich hab den Fehler :
KR-29.

No valid font found in PUBDATA\FONT folder.

- Keinen gültigen Font im Verzeichnis 'PUBDATA\FONT' gefunden

Lösung ?( ?( ?( ?(

Nach der Installation von Geos 2.01 D
Gruß Uwe

5

Montag, 15. Januar 2018, 00:05

Die Fehlermeldung tritt auf (wenn ich mich richtig erinnere), wenn in der GEOS.INI der falsche Treiber für das Dateisystem ausgewählt ist. DOSBOX-Emu benötigt den NTFAT-Treiber / OS2-Treiber, ein altes DOS 6 den MSDOS4-Treiber. Bei dem DOS aus Win98 bin ich mir nicht sicher, einfach ausprobieren. Könnte ich notfalls mal auf meinem DOS-Rechner nachsehen.
»Mütze« hat folgende Bilder angehängt:
  • FS2.GIF
  • FS.GIF
Bernd

6

Montag, 15. Januar 2018, 17:53

USERDATA/FONT-Problem beim starten

Bei mir tritt dies regelmäßig auf, wenn ich in der DOSBox eine GEOS-Standard-Installation verwendet, dabei den Filesystem-Treiber nicht von ms4.geo auf os2.geo umstelle. Allgemein würde ich also auf File-System-Treiber-Einstellung tippen. Welches DOS hast Du drunter?

7

Montag, 15. Januar 2018, 18:26

Habe nachgeschaut, bei meinem MSDOS 7 ist auch der MSDOS4-Treiber eingestellt. Per TXT-Editor im Bereich 'system' der GEOS-INI eintragen:

fs = ms4.geo
Bernd

8

Montag, 15. Januar 2018, 18:52

Hallo!


KR-29. No valid font found in PUBDATA\FONT folder.


In 98% aller Fälle tritt das Problem auf, wenn der falsche FileSystem-Treiber in der GEOS.INI eingestellt ist. Zur Behebung haben die anderen schon genug geschrieben. (Zusatzinfo: Je nach DOS-Version reicht es auch, dass das DOS einfach eine "von Geos unterstützte" Versionsnummer liefert -> siehe DOS-Befehl "SETVER", den es aber nicht bei allen DOS-Versionen gibt und der auch nicht immer hilft.) Sonst: Siehe Geoswiki (mit den weiteren Seiten am Ende des allgemeinen Teils)
In 1% aller Fälle tritt das Problem trotz richtiger FS-Einstellung auf, wenn es das "DOS" nicht erlaubt, genügend Dateien gleichzeitig zu öffnen. (FILES=120 in der CONFIG.SYS oder ähnlichen Konfigurationsdateien hilft hier.)

So oder so: Das ganze ist eigentlich eine "falsche Fehlermeldung", da das eigentliche Problem nichts mit den Fonts im Speziellen, sondern mit dem Dateizugriff im Allgemeinen zu tun hat.
d[ 0_O ]b

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

9

Montag, 15. Januar 2018, 19:56

Hallo Danke für die vielen Antworten.

Also ich habe mir das Dos von Win95b genommen da das 32Bit nutzen kann..
das ist der Hauptgrund.

Ich habe mein altes Geos 2.01D genommen und installiert..

@bernd ich hab mir die Geos.ini über den Norton Comander angeschaut aber einen Eintrag für das FS habe ich nicht gefunden.. ?( 8|

@jpolzfuss Ich hab Files=120 in der Config eingetragen aber das war leider nicht die Lösung. der Eintrag macht aber den Hauptspeicher kleiner . Ich denke Files=40 reicht voll aus..

Gruß Uwe

10

Montag, 15. Januar 2018, 20:10

1. Wenn der Eintrag fehlen sollte, füge ihn einfach hinzu.

2. Files = 40 ist für GEOS definitiv zu wenig. 80 ist minimum, 120 ist richtig gut. Spare lieber an anderer DOS-Treiber-Stelle.
»Mütze« hat folgendes Bild angehängt:
  • FS3.GIF
Bernd

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

11

Montag, 15. Januar 2018, 20:18

1. Wenn der Eintrag fehlen sollte, füge ihn einfach hinzu.

2. Files = 40 ist für GEOS definitiv zu wenig. 80 ist minimum, 120 ist richtig gut. Spare lieber an anderer DOS-Treiber-Stelle.
Hallo Bernd
ich habe die beide Einträge geändert ..

ich werde das mal ausprobieren... sage dir gleich mal ob es funkst
:D :D :D :D

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

12

Montag, 15. Januar 2018, 20:24

hallo
es funkst aber die Dos Maus Läuft nicht ..
unter NC hat sie Funktion
Gruß Uwe

13

Montag, 15. Januar 2018, 20:51

In den GEOS Voreinstellungen -> Maus den 'DOS-Maustreiber' auswählen.
Bernd

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

14

Montag, 15. Januar 2018, 21:08

In den GEOS Voreinstellungen -> Maus den 'DOS-Maustreiber' auswählen.
In den GEOS Voreinstellungen -> Maus den 'DOS-Maustreiber' auswählen.
Jaap hab ich schon selbst gefunden aber danke .... :D :D :D

Gruß Uwe

15

Montag, 15. Januar 2018, 21:57

Dos von Win95b ... Hauptspeicher

Eine der Win95-Versionen hatte einen Fehler im DOS, wodurch in DOS immer 64kb zu wenig frei gegeben wurde. Ich weiß aber nicht mehr, in welcher Version das war...
d[ 0_O ]b

16

Montag, 15. Januar 2018, 22:09

Es waren scheinbar weniger als 64kb - Zitat von http://www.winfaq.de/faq_html/Content/ti…p?h=tip0342.htm

OEM Service Release 2 (ab hier "B-Version"):
4.00.1111 b
Dies ist das OEM Service Release 2, das es aber nicht als Update gibt.
Es ist aber möglich, die Installationsdateien zu modifizieren, so dass man die Komplett-Version doch zum Updaten benutzen kann.
Unter "Systemsteuerung - System" wird das OSR 2 als 4.00.950b angegeben. In der DOS - Eingabeaufforderung wird korrekt 4.00.1111 angezeigt. Ab dieser Version ist auch die MS-DOS Version 7.1 dabei. Die Datei "Io.sys" enthält einen Fehler, der dazu führt, dass der Treiber "Himem.Sys" 45 KB belegt, hierfür gibt es aber einen offiziellen Patch, der den Fehler behebt.
d[ 0_O ]b

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

17

Montag, 15. Januar 2018, 23:12

Es waren scheinbar weniger als 64kb - Zitat von http://www.winfaq.de/faq_html/Content/ti…p?h=tip0342.htm

OEM Service Release 2 (ab hier "B-Version"):
4.00.1111 b
Dies ist das OEM Service Release 2, das es aber nicht als Update gibt.
Es ist aber möglich, die Installationsdateien zu modifizieren, so dass man die Komplett-Version doch zum Updaten benutzen kann.
Unter "Systemsteuerung - System" wird das OSR 2 als 4.00.950b angegeben. In der DOS - Eingabeaufforderung wird korrekt 4.00.1111 angezeigt. Ab dieser Version ist auch die MS-DOS Version 7.1 dabei. Die Datei "Io.sys" enthält einen Fehler, der dazu führt, dass der Treiber "Himem.Sys" 45 KB belegt, hierfür gibt es aber einen offiziellen Patch, der den Fehler behebt.
Hmm welches Dos sollte man denn nehmen..?
MSDOS 6.22 16.bit
DRDOS 7.0 16 bit
das von Win98SE 32 Bit
WinXP 32 Bit dosbox das kann jeder 8o 8o 8o 8o 8o


Das einzige was mich an win95B und Win98se stört ist das Start Logo.
Man konnte das irgendwie abschalten ... aber das weiß ich nicht mehr.

Ich würde gern das DOS von win98SE verwenden wenn das StartLogo nicht mehr das wäre..
Gruß Uwe

18

Dienstag, 16. Januar 2018, 00:43



Das einzige was mich an win95B und Win98se stört ist das Start Logo.
Man konnte das irgendwie abschalten ... aber das weiß ich nicht mehr.

Ich würde gern das DOS von win98SE verwenden wenn das StartLogo nicht mehr das wäre..
Gruß Uwe
Schaue dir mal die Konfiguration meines DOS-Rechners an. Habe auch das DOS aus Win 98SE verwendet:

http://www.geopixel.de/GEOSPC/IGL32KNF.HTM
Bernd

stlinky

Anfänger

  • »stlinky« ist der Autor dieses Themas

Beiträge: 27

Beruf: Komunikationselektroniker Bereich Informationstechnik

  • Nachricht senden

19

Sonntag, 21. Januar 2018, 15:13



Das einzige was mich an win95B und Win98se stört ist das Start Logo.
Man konnte das irgendwie abschalten ... aber das weiß ich nicht mehr.

Ich würde gern das DOS von win98SE verwenden wenn das StartLogo nicht mehr das wäre..
Gruß Uwe
Schaue dir mal die Konfiguration meines DOS-Rechners an. Habe auch das DOS aus Win 98SE verwendet:

http://www.geopixel.de/GEOSPC/IGL32KNF.HTM
Hallo Bernd

Ich hab mir die Einstellungen der MsDos.sys angeschaut und übernommen.. und es funkst Danke.. :D 8o :thumbup:
Was mir nur aufgefallen ist der der Boot.log immer noch gemacht wird .
Es gibt zwar eine Einstellungen in den option das er nicht mehr gemacht werden soll (DisableLog= Create BOOTLOG.TXT upon bootup. The default is 1.) aber der funkst nicht so wiklich.
Ist das bei dir auch so ?

Hat jemand nocht eine andere Lösung dafür ?

Gruß Uwe

20

Samstag, 14. April 2018, 20:35

Dos 7.1 pur, ohne win:
https://archive.org/details/dos71cd

Sehr gute Anleitung und Info:
https://baike.baidu.com/item/MS-DOS (mit Googel Translate)

Gruß, Wolfgang

Zur Zeit sind neben Ihnen 2 Benutzer in diesem Thema unterwegs:

2 Besucher

Thema bewerten