Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GEOS-InfoBase-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

121

Sonntag, 8. Mai 2016, 21:36

Hallo zusammen

Ich habe nun auf meinem 64-bit Ubuntu auch den 2-zeiligen Patch eingespielt und kann nun mit höheren Farbtiefen spielen. Der Speed-Wert "11400" mit 800x600 und 16 Farben kann ich damit aber natürlich nicht mehr halten (sniff):
  • 800x600 256 Farben -> Speed 10200
  • 800x600 32k Farben -> Speed 9700
  • 800x600 64k Farben -> Speed 9100
  • 1024x600 64k Farben -> Speed 6600
Wenn jemand vollen Speed benötigt, dann geht nichts über die "alten" Treiber.

Einzig True-Colour ging nicht. GEOS findet den VGA-Adapter nicht passend. Im Moment verwende ich den 1024x600 64k Modus, da darin die weissen Pixel von der Maus nicht auftreten.

Ist eigentlich der 256-Farben-Treiber derjenige, welcher es als Update gab ?

Gruss
Andreas

122

Dienstag, 12. Juli 2016, 14:16

DOSEmu2 mit KVM - Update 2

Hallo zusammen

Der aktuellste Entwicklungs-Stand bei DOSEmu2 zeigt erfreuliche Fortschritte.

System:
  • CPU Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
  • Ubuntu 16.04 LTS 64-bit
  • DOSEmu2 mit KVM als CPU-Emulator

VESA 800x600 in 16 Farben


VESA 1024x768 in 65536 Farben


Der Unterschied von 800x600 in 16 Farben zu 1024x768 in 65536 Farben ist fast weg... Die Entwickler geben sich richtig Mühe.

Andreas

123

Freitag, 15. Juli 2016, 20:39

DOSEmu2 mit KVM - Update 3

So, nur um Euch noch mehr zu nerven, hier eine Version von meinem alten PC am Arbeitsplatz.

- Intel Core i7 2600 @ 3.4GHz
- Ubuntu 16.04 32-bit
- KVM (nicht VM86, das geht da im Moment nicht)
- 1024x768 mit 16-bit Farben (64k)



PS:
Man kann das natürlich ohne Probleme toppen. Dazu schiebt man ein anderes Fenster über Speed, beendet GEOS und startet es neu. Nun 10 Sekunden warten bis Speed durch ist. Danach kann man sich beim Wegschieben des überlagernden Festers über den "Megascore" im Speed freuen... Schiebung! Hab das aus Zufall mal selbst produziert. Hatte Werte um 37000 auf einem langsameren Gerät ;-)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »bolle732« (15. Juli 2016, 21:17)


124

Montag, 23. Januar 2017, 13:26

DOSEmu2 mit KVM - Update 4

Neuestes von der DOSEMU2-Front:

Mit der aktuellen Entwickler-Version bringt Speed im SDL-Modus nur noch 1/3 der Leistung (3800 vs 11200 auf meinem i7-5500U Notebook mit integrierter Intel-Grafik).

Dafür läuft der X-Modus wieder (Option "-X" der "dosemu.bin"), und der bringt Speed auf Werte um 15000. Das entspricht denen des Core i7 2600 Rechners mit dedizierter AMD-Grafikkarte.
  • CPU Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
  • Ubuntu 16.04 LTS 64-bit
  • DOSEmu2 mit KVM als CPU-Emulator und X-Modus
VESA 1024x768 in 65536 Farben


Weiter ist die CPU-Benutzung bei ruhendem PC/GEOS-Desktop von ~48% auf ~6% (SDL) und ~2% (X) gesunken.

Wenn sonst keine Probleme auftreten, dann empfehle ich die aktuellste Entwicker-Version im X-Modus. Besonders, wer auf einem Notebook arbeitet (Stromverbrauch).

125

Montag, 23. Januar 2017, 13:41

Habe vom Entwickler erfahren, dass der Wechsel Fenster zu Vollbild und zurück unter X Probleme machen kann. Ich selber brauche das nie. Wie sieht das bei Euch aus ?

126

Montag, 23. Januar 2017, 15:25

Habe vom Entwickler erfahren, dass der Wechsel Fenster zu Vollbild und zurück unter X Probleme machen kann. Ich selber brauche das nie. Wie sieht das bei Euch aus ?
Zu Beginn habe ich das mal verwendet, jetzt aber schon lange nicht mehr. Ich brauche es eigentlich auch nicht.
Gruß Achim



PC/GEOS unter Linux in der DOSEMU = UNSCHLAGBAR!

127

Dienstag, 24. Januar 2017, 13:31

Hallo,
Habe vom Entwickler erfahren, dass der Wechsel Fenster zu Vollbild und zurück unter X Probleme machen kann. Ich selber brauche das nie. Wie sieht das bei Euch aus ?
das Vollbild nutze ich nur gelegentlich, da es bei größeren Monitoren (1980 x 1080) bei mir nicht richtig funktioniert. Bei Auflösungen von 1024 x 768 kein Problem.

Jens
- geos-tiger -

128

Donnerstag, 26. Januar 2017, 13:09

DOSEmu2 mit KVM

Hallo Andreas,

Geos läuft jetzt auf meinem Laptop (ThinkPad E460/ 14er/1920x1080 i5) in der Dosemu2 mit KVM Auflösung ist 1280 x 768. Speed = 7900. Hast Du mal das Programm GeoCosmos 2.40 gestartet? Bei mir stürzt Geos dann ab.
Habe Deine Einstellungen für die dosemu.conf und autoexec und config übernommen.

Jens
- geos-tiger -

129

Donnerstag, 26. Januar 2017, 15:44

Hallo Andreas,

Geos läuft jetzt auf meinem Laptop (ThinkPad E460/ 14er/1920x1080 i5) in der Dosemu2 mit KVM Auflösung ist 1280 x 768. Speed = 7900. Hast Du mal das Programm GeoCosmos 2.40 gestartet? Bei mir stürzt Geos dann ab.
Habe Deine Einstellungen für die dosemu.conf und autoexec und config übernommen.

Jens
Hallo Jens.
Hast du schon mal versucht, dosemu2 mit der Option X zu starten? Siehe Andreas' Beitrag weiter oben.
Gruß Achim



PC/GEOS unter Linux in der DOSEMU = UNSCHLAGBAR!

130

Donnerstag, 26. Januar 2017, 19:35

DOSEmu2 mit KVM

Hallo,

@ Achim,
ja, habe ich jetzt einmal gemacht. (dosemu starten mit: dosemu -X) Speed liegt jetzt bei 13100/13200. Aber GeosCosmos 2.40 startet trotzdem nicht. Werde mal warten bis Andreas sich gemeldet hat.

Nachtrag:
GeoCosmos startet jetzt. Ich habe den Auslöser gefunden. In der geos.ini hatte ich in dem Bereich [math] einen coprocessor intx87 eingetragen. Damit kommt anscheinend die neue dosemu2 oder aber meine neue Hardware nicht zurecht.

Jens
- geos-tiger -

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Geos-Tiger« (28. Januar 2017, 12:04)


131

Sonntag, 29. Januar 2017, 21:02

Hallo Andreas,

Geos läuft jetzt auf meinem Laptop (ThinkPad E460/ 14er/1920x1080 i5) in der Dosemu2 mit KVM Auflösung ist 1280 x 768. Speed = 7900. Hast Du mal das Programm GeoCosmos 2.40 gestartet? Bei mir stürzt Geos dann ab.
Habe Deine Einstellungen für die dosemu.conf und autoexec und config übernommen.

Jens

Hallo Jens

Hatte vor ein paar Tagen die DOSEMU2 zu Hause noch schnell aktualisiert, bevor die Kinder das Club 2% spielten. Dieses ist dann immer nach kurzer Zeit mit zuwenig konventionellem Speicher abgeschmiert. Der Grund war, dass die "ems.sys" nicht mehr geladen wurde, weil ich vergass, die neue Version in mein "drive_c" reinzukopieren.

GeoCosmos habe ich auf diesem und einem anderen Notebook probiert. Hier ist es die 2.40 in Deutsch, die ist in einer Sekunde geladen. Sprich, der Berechnungsbalken macht einfach "wuuusch"...

Absturz gab es keinen bis jetzt, hatte fast alle Funktionen von GeoCosmos probiert.

Nachtrag:
Auch auf dem zweiten Notebook läuft GeoCosmos 2.40 (in Englisch) ohne Probleme.

Gruss
Andreas

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »bolle732« (30. Januar 2017, 11:39)


132

Montag, 30. Januar 2017, 14:19

Hallo Andreas,

GeoCosmos läuft bei mir jetzt ohne Probleme. (Siehe vorigen Beitrag von mir) Da Du die ems.sys ansprichst, habe ich eine Frage: In der dosemu.conf gibt es ja einen Eintrag "ems". Welche Einstellung hast Du da jetzt eingestellt? ems=(0) oder ems=(off). -In einem anderen Beitrag hattest Du bei der dosemu.conf den ems-Speicher auf 0 gesetzt.- Wenn der ems-Speicher auf 0 gesetzt ist warum gab es dann Probleme mit Geos weil die ems.sys nicht vorhanden war?

Jens
- geos-tiger -

133

Montag, 30. Januar 2017, 17:34

Hallo Jens

Ich habe zwar EMS deaktiviert ("$_ems = (0)"), aber ohne die "ems.sys" gibt es auch keinen XMS und UMB Speicher... Eigentlich müsste die Datei "mem.sys" oder so ähnlich heissen.

Auf jeden Fall, passt die Version von "ems.sys" nicht zur installierten Version der DOSEM(2), hat man nur den konventionellen Speicher zur Verfügung.

Gruss
Andreas

134

Mittwoch, 1. März 2017, 11:19

Speed aktuelle Werte

Hallo Bernd,

hier meine aktuellen Werte:

Lenovo ThinkPad E460, Prozessor Intel Core i5-6200U, OS Linux: Xubuntu 16.10, 14 Zoll Display Auflösung 1920x1080 HD

Dosemu2 im X-Fenster
Geos Auflösung 1280 x 854 64k Speed: 13300, Perf 6553,5

Habe mal die Maximaleinstellung auf meinem Display ausprobiert.
Geos Auflösung 1920 x 1024 64k, Speed: 13100

(Bei dieser Auflösung werden aber speziell die älteren Icons zu klein oder nur in schwarz/weiß angezeigt. Außerdem werden die Programme
in Bildschirmgrösse gestartet und nicht mehr angepasst. )

Jens
- geos-tiger -

135

Donnerstag, 2. März 2017, 19:21

Hallo Bernd, hier meine aktuellen Werte
Danke Jens, habe die Liste ergänzt. Verrätst du bitte noch die Geschwindigkeit deines Prozessors? :D
Bernd

136

Donnerstag, 2. März 2017, 21:53

Hallo Bernd,
Danke Jens, habe die Liste ergänzt. Verrätst du bitte noch die Geschwindigkeit deines Prozessors? :D
hier der komplette Wert: Intel Core i5-6200U 2800 MHz Xubuntu 16.10 64bit

Jens
- geos-tiger -

137

Sonntag, 5. März 2017, 18:24

Hallo Bernd,
Danke Jens, habe die Liste ergänzt. Verrätst du bitte noch die Geschwindigkeit deines Prozessors? :D
hier der komplette Wert: Intel Core i5-6200U 2800 MHz Xubuntu 16.10 64bit
:thumbsup:
Bernd

Frank9652

Fortgeschrittener

Beiträge: 399

Beruf: Backup-Administrator

  • Nachricht senden

138

Donnerstag, 30. Juli 2020, 08:43

Ich habe jetzt mal die Geschwindigkeit von Geos auf meinem neuen Laptop messen wollen.

Der neue Laptop hat ja als CPU einen AMD Ryzen 5 4500U Prozessor (6 Kerne, 6 Threads, 8 MB Cache, bis zu 4,00 GHz)
Sowie 8 GB DDR4 3,200 MHz RAM

Wie empfohlen hatte ich zuerst Geos incl. DOSBox mit Dosbox-Konfigurationsdatei 1:1 auf den neuen Rechner kopiert.
Vorher lief Geos in der DOSBox ja auf meinen Eee-PC. Dort hatte ich in der Dosbox-Konfigurationsdatei so lange mit der Einstellung
[cpu]
cycles=fixed nnnn
herumgespielt, bis ich keine messbare Geschwindigkeitssteigerung auf dem Eeepc bei dem Wert 110000 mehr feststellen konnte.
Die Geschwindigkeit von Speed lag hier bei dem EePC bei 6900, und bei Perf bei 520,6.

Bei dem Cycles-Wert von 110000 kam Speed bei dem neuen Laptop auf exact den selben Wert von 6900, und Perf auf 520,6.
Nun steigerte ich langsam der Wert von Cycles bis auf 1400000.
Nun Zeigte mir Speed den Wert 62300 und Perf den Wert 6553,5 an.
Ich hatte auch mal als Cycleswert 2000000 eingestellt. Da zeigte mir dann Speed zwar 80200 an und Perf immer noch 6553,5.
Ich vermute, dass Perf hier an das Maximum seiner Messgrenze gestoßen ist, und deshalb keinen höheren Wert anzeigt.
Aber ich hatte den Eindruck, das Geos nicht mehr schneller als bei dem Wert 1400000 geworden war.

Ich werde noch die ganzen Einstellungen nochmal durchführen müssen, indem ich dann bei jeder Einstellung komplexe Operationen mitGeocalc durchführe, und dabei dann die Zeit mit dem Handy stoppe. Aber auch das wird schwierig bezüglich der Genauigkeit werden.
Während ich bei dem EeePC bei bestimmten Berechnungsmethoden in einem Calcdokument gut mehrere Minuten habe warten müssen, konnte
ich auf dem neuen Rechner bei einem groben Überblick eine Berechnungszeit von 7-8 Sekunden feststellen.

Erstes Fazit:
Die Geschwindigkeit von Geos unter Dosbox hängt nicht nur von der CPUgeschwindigkeit ab, sondern auch in wie weit man in der DOSBox.conf den Wert der Cycles an die CPUGeschwindigkeit angepasst hat. Es nützt die schnellste CPU nichts, wenn man in der Dosbox.conf einen niedrigen Cycles-Wert eingestellt hat.

Gruß Frank
Geos x Asus EeePC 1015PN + SSD = doppelte Lichtgeschwindigkeit zum Quadrat

Frank9652

Fortgeschrittener

Beiträge: 399

Beruf: Backup-Administrator

  • Nachricht senden

139

Freitag, 31. Juli 2020, 07:34

So, ich habe jetzt noch einmal eine "unkonventionelle" Messmethode gewählt.


Ich habe ein recht umfangreiches ausgefülltes GeoCalcdokument genommen und habe etwas über 50 ausgefüllte Zeilen mit leeren Zellen aus der Zwischenablage überschrieben. - Bei komplizierten Calctabellen mit vielen Formaln kann das eine ganz schöne Weile dauern, weil alle Ergebniswerte immer neu berechnet werden müssen.
Parallel dazu habe ich bei diesem Überschreibungsvorgang die Stoppuhr auf dem Handy mitlaufen lassen. Bedingt durch die Reaktionszeit der Finger sind dabei aber schon auch Toleranzen von 1- 1,5 Sekunden möglich.

Bei Cycles 110000 hatte der Überschreibungsvorgang 21,68 Sekunden gedauert.
Bei Cycles 500000 hatte der Überschreibungsvorgang 11,79 Sekunden gedauert.
Bei Cycles 1000000, 1200000, 1400000, 1600000, 1800000, 2000000 und 2500000 bewegten sich die Werte zwischen 11,75 und 12,89 Sekunden was ich der Ungenauigkeit zurechne.

Also nach der Cycleeinstellung von 500000 konnte ich keine signifikante Geschwindigkeitsverbesserung mehr feststellen, obwohl Speed bei höheren Werten auch eine höhere Geschwindigkeit ausgewiesen hatte.

Ich habe deshalb die Cycles jetzt auf 500000 eingestellt.
Gruß Frank
Geos x Asus EeePC 1015PN + SSD = doppelte Lichtgeschwindigkeit zum Quadrat

140

Dienstag, 4. August 2020, 12:08

Hallo Frank,

nimm GeoCosmos zum Vergleich. Wenn der Berechnungsbalken auf einem modernen PC in ca. 1 Sekunde durchgelaufen ist, dann wird die DOS-Umgebung für GeoWorks sehr schnell emuliert. Wahrscheinlich bekommt die Emulation für DOS dann einen eigenen CPU-Kern.

Viele Grüße

Uli
Ulrich Cordes

>>> Je weniger WINDOWS um so besser. <<< :D

Zur Zeit sind neben Ihnen 2 Benutzer in diesem Thema unterwegs:

2 Besucher

Thema bewerten