Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GEOS-InfoBase-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Frank9652

Fortgeschrittener

Beiträge: 320

Beruf: IT-Betriebssupporter

  • Nachricht senden

41

Samstag, 27. April 2013, 13:40

Ich benutze keine DOS-Box.

Hab grade mal nachgesehen, ich benutze den angepassten GDI-Treiber von Uli. (kam vorher nicht auf den Namen).
Als Unterbau Windows 7, dann den GDI-Treiber mit 800x600 Fenster, worunter Geos läuft.
Unter Geos hatte ich natürlich sämtliche im Hintergrund laufenden Programme beendet. (war sowieso nur die Uhr).
Dann werden die Performanceschwankungen wohl von Windows 7 Programmen resultieren, die im Hintergrund werkeln. (Avira oder sonstiges).

Gruß Frank
Geos x Asus EeePC 1015PN + SSD = doppelte Lichtgeschwindigkeit zum Quadrat

42

Samstag, 27. April 2013, 13:53

Version 0.53 hochgeladen. Das Icon habe ich noch einmal neu gezeichnet, nun sollte es mittig sitzen. Damit es angezeigt wird, muss das evtl. vorhandene alte Icon in der Token Database z.B. mit Tune Pro oder Token Deleter gelöscht werden. Ausserdem habe ich die Anzeige der Schwankungen etwas abgemildert, die Werte werden nun in 100er-Schritten angezeigt. Meinungen dazu sind wieder sehr willkommen.
Bernd

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mütze« (27. April 2013, 14:01)


43

Samstag, 27. April 2013, 14:14

Ich bin mit der Streuung sehr zufrieden. In Dosemu, Mint13/14 mit Cinnamon/Mate auf demselben Rechner erhalte ich Werte zwischen 3000 und 3100, meist liegen die Werte zwischen 3013 und 3017.
Läuft gleichzeitig "Avatar" in der mkv - Version, liefert Speed nur noch 2100 - 2200.

Sehr gut, danke. Dein Hinweis auf parallele Aktionen (Video laufen lassen) deckt sich mit "Geos-Tigers" Anmerkungen zum gleichen Thema, womit der Zusammenhang endgültig bewiesen sein dürfte.
Bernd

44

Samstag, 27. April 2013, 14:24

Ich könnte mir vorstellen, dass eine "übertaktete" DOS-Box besonders schwankende Werte liefert - was auszuprobieren wäre ;-)

Nö, Schwankungen gibt es genauso wenige wie bei richtig eingestellten Cycles (dafür müssen einmal die 5 Sek. des Speedtests handgestoppt und die ermittelten richtigen Cycles in die DOSBOX-Ini eingetragen werden). Wenn ich die Cycles stattdessen auf den dreifachen Wert setze, läuft Speed auch knapp drei mal so lange. :D
Das Ergebnis (dreifacher Wert) sieht dann zwar richtig gut aus, ist aber halt mächtig geschummelt und hat wenig mit der tatsächlich erreichten Geschwindigkeit zu tun.

Nachtrag: Das habe ich nur mit DOSBox für OS X ausprobiert. Durchaus möglich, dass sich DOSBox für Windows (oder einem anderen System) anders verhält.
Bernd

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mütze« (27. April 2013, 14:38)


45

Samstag, 27. April 2013, 14:54

Als Unterbau Windows 7, dann den GDI-Treiber mit 800x600 Fenster, worunter Geos läuft.
Unter Geos hatte ich natürlich sämtliche im Hintergrund laufenden Programme beendet. (war sowieso nur die Uhr). Dann werden die Performanceschwankungen wohl von Windows 7 Programmen resultieren, die im Hintergrund werkeln. (Avira oder sonstiges).

Man könnte den Speedtest auch als Hilfsmittel betrachten, das Hinweise auf besonders performancehungrige Hintergrundprogramme liefert. Wenn ich mich richtig erinnere, können sich Anti-Viren Programme bei der Prozessorauslastung stark unterscheiden - ohne in der Erkennungsleistung sehr unterschiedlich zu sein.

Es gibt doch für Windows bestimmt so was wie einen "Performance-Monitor", den man einige Minuten beobachten könnte, um zu sehen, welche Programme aktuell wie viel Prozessorleistung verbrauchen.
Bernd

46

Samstag, 27. April 2013, 17:11

Hier einige aktuelle Werte, gemessen mit Speed 0.53

Pentium II 233 MHz, MSDOS 6.22, GEOS4 ------------------ Perf: 1435 Speed: 2000
Pentium II 233 MHz, Windows 98SE, GEOS4 --------------- Perf: 1424 Speed: 1800
Core2Duo 1.86 GHz, OSX 10.8, DOSBox, GEOS4 ---------- Perf: 71 Speed: 800
GlobalPC, Elan SC410 100 MHz, RomDos 6.22, GEOS4 -- Perf: 210 Speed: 500
Bernd

47

Sonntag, 28. April 2013, 19:08

Hallo Bernd,

habe geade dein Speed benutzt um die Geschwindigkeit meiner DOSBox anzupassen. Die Rundung auf 100 gefällt mir gar nicht, das ist viel zu grob. Um eine Programmidee draus zu machen: Ein Selektor
Runden # auf 100 # auf 10 # gar nicht
Wäre doch etwas, oder ;-)

Gruß
Rainer

P.S. Den aber NICHT innerhalb der Schleife abfragen!
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

48

Sonntag, 28. April 2013, 19:40

habe geade dein Speed benutzt um die Geschwindigkeit meiner DOSBox anzupassen. Die Rundung auf 100 gefällt mir gar nicht, das ist viel zu grob. Um eine Programmidee draus zu machen: Ein Selektor Runden # auf 100 # auf 10 # gar nicht. Wäre doch etwas, oder ;-)

Ich hab's geahnt... :D

Persönlich gefällt mir die 100er Teilung gut, weil sie zum vergleichen der Geschwindigkeit genau genug ist. Auch weil man den Unterschied, ob GEOS 1000 oder 1100 erreicht, meiner Meinung nach nicht spüren kann. Für exaktere Messungen ist das aber natürlich nix. Also schaue ich mal, ob ich da was basteln kann.

Zitat

P.S. Den aber NICHT innerhalb der Schleife abfragen!

Logo.
Bernd

49

Sonntag, 28. April 2013, 22:15

Version 0.60 hochgeladen. Nun mit Auswahl der Schrittweite. http://www.geopixel.de/RBPROGS/SPEED.HTM

Am 29.05.13 den Link geändert.
Bernd

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mütze« (29. Mai 2013, 20:07)


50

Sonntag, 28. April 2013, 22:20

Zitat von »geobart«



Ich bin mit der Streuung sehr zufrieden. In Dosemu, Mint13/14 mit Cinnamon/Mate auf demselben Rechner erhalte ich Werte zwischen 3000 und 3100, meist liegen die Werte zwischen 3013 und 3017.
Läuft gleichzeitig "Avatar" in der mkv - Version, liefert Speed nur noch 2100 - 2200.
Mint liefert den "Systemmonitor" (gnome-system-monitor) mit, der u.a. Prozessorauslastung und Speicherbedarf liefert. Im "Normalbetrieb" habe ich ( Core 2) je Kern eine durchschnittliche Prozessorausnutzung von unter 10%. Speed kommt dann auf Werte ab 3000 und höher.
"Avatar" in der mkv - Version ( VLC in Vollbild )) ist das Prozessorhungrigste, das ich zum Testen habe: beide Kerne werden zusammen bis zu 180% belastet. Bei Spitzenbelastung (schnelle, aufwändige Kampfszenen) geht der Speed-Wert bis auf 1800 runter; in ruhigen Szenen auf 2200 rauf.

Dein Hinweis auf parallele Aktionen (Video laufen lassen) deckt sich mit "Geos-Tigers" Anmerkungen zum gleichen Thema, womit der Zusammenhang endgültig bewiesen sein dürfte.
Deshalb dieser etwas genauere Nachtrag. :)


Wolfgang

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »geobart« (28. April 2013, 22:44)


51

Montag, 29. April 2013, 20:18

Deshalb dieser etwas genauere Nachtrag. :)
Klasse Wolfgang, danke. :thumbsup:
Bernd

52

Montag, 29. April 2013, 20:24

Vorhin Version 0.61 hochgeladen. Jetzt muss man sich nicht mehr vor der Messung für eine Schrittweite entscheiden, sondern kann auch danach zwischen den drei Anzeigeformaten hin und her schalten. Der aktuell angezeigte Wert kann dann bei Bedarf gespeichert werden.
Bernd

53

Dienstag, 30. April 2013, 09:21

Hallo,

auch ein paar Werte:

VIA C3 700 MHz, MS-DOS 8.00, BBE 4.13 ------------------------ Perf: 1660; Speed: 4000*
Core i5-3470 3.20 GHz, Win7-64 + DosBOX MB6, NDO 3.2a --- Perf: xx**; Speed: 2600
C2D L9300 1.66 GHz, Mint 14.1 + Dosemu, BBE 4.13 ---------- Perf: 6337; Speed: 2500
C2D ??? 2.4 GHz, OS X 10.6, NDO 3.2a -------------------------- Perf: 162; Speed: 1700

Gefühlt würde ich sagen, dass die BosBOX eher besser läuft, weil der Bildschirmaufbau schneller ist. Aber Speed testet ja auch nicht die I/O-Leistung sondern nur, wie schnell man den Timer abfragen kann :D Vielleicht würde eine Art 'Bounce' mit 16-bit JPEG Bildern hier realistischere Ergebnisse liefern. So als Vorschlag für Version 2...

*) 3500 ohne UniVBE; siehe Posting weiter unten

**) Ich habe ab heute Urlaub und diesen Wert gibt's erst in 2 Wochen 8)

Gruß Thomas

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »t.hass« (30. April 2013, 22:27)


Frank9652

Fortgeschrittener

Beiträge: 320

Beruf: IT-Betriebssupporter

  • Nachricht senden

54

Dienstag, 30. April 2013, 14:36

Grundsätzlich würde ich sagen -> Gute Idee.
...aber nicht mit JPEG, da es ja zur Anzeige dekomprimiert werden muss. Bei langsamen Rechnern kann es da schon zu Unterschieden kommen.
Und wenn man das Bild wechselt, dann würden sich auch die Werte ändern, da ein Bild mit überwiegendem hellen Anteil eine andere Zeit für Kompression/Dekompression benötigt, als ein Bild mit überwiegendem dunklen Bereichen.
Wenn Bild, dann eines mit einem unkomprimierten Format, und dann evtl. auch eines in dem die hellen und dunklen Bereiche ausgewogen verteilt sind.

Gruß Frank
Geos x Asus EeePC 1015PN + SSD = doppelte Lichtgeschwindigkeit zum Quadrat

55

Dienstag, 30. April 2013, 15:38


VIA C3 700 MHz, MS-DOS 8.00, BBE 4.13 ------------------------ Speed: 3500
Core i5-3470 3.20 GHz, Win7-64 + DosBOX MB6, NDO 3.2a --- Speed: 2600

Danke für's ausprobieren, deine Werte übernehme ich in die kleine Liste auf geopixel.de. Könntest du vielleicht noch die Perf-Werte nachreichen?

Zitat

Gefühlt würde ich sagen, dass die BosBOX eher besser läuft, weil der Bildschirmaufbau schneller ist. Aber Speed testet ja auch nicht die I/O-Leistung sondern nur, wie schnell man den Timer abfragen kann :D Vielleicht würde eine Art 'Bounce' mit 16-bit JPEG Bildern hier realistischere Ergebnisse liefern. So als Vorschlag für Version 2...

Hmm, mit der Thematik kenne ich mich ja nicht wirklich aus, aber dem "... testet nur, wie schnell man den Timer abfragen kann" habe ich entgegen zu wirken versucht, indem bei jedem Schleifendurchlauf die Bitmap zur Anzeige des Wertes neu gezeichnet wird. In wieweit das ne gute Möglichkeit zur Leistungsmessung ist, kann ich wiederum nicht sagen...

Zu JPGs: Ich nutze z.B. GEOS im 256-Farben Grafikmodus und da ist die Darstellung von JPGs extrem langsam, womit sich in Bezug auf die allgemeine Geschwindigkeit des Systems wieder ein verfälschter Wert ergeben könnte.
Bernd

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Mütze« (30. April 2013, 15:44)


56

Dienstag, 30. April 2013, 22:05

Hallo Bernd,
...habe ich entgegen zu wirken versucht, indem bei jedem Schleifendurchlauf die Bitmap zur Anzeige des Wertes neu gezeichnet wird. In wieweit das ne gute Möglichkeit zur Leistungsmessung ist, kann ich wiederum nicht sagen...
Asche über mein Haupt. Den Print-Befehl habe ich, wie ich gerade feststellen musste, zu Unrecht unterschlagen :S Um den Perf-Wert zu ermitteln habe ich den GEOS-Igel noch mal angeworfen, diesmal aber mit geladenem UniVBE+VBEHZ (eigentlich nur damit er 60 Hz macht und mich das TFT nicht nervt). Jetzt komme ich reproduzierbar auf 4000 vs. 3500 "Runden". Offensichtlich kitzelt UniVBE noch etwas mehr (~14%) Leistung aus der Grafikkarte und Speed's "Print" profitiert davon :thumbup:
Ich nutze z.B. GEOS im 256-Farben Grafikmodus und da ist die Darstellung von JPGs extrem langsam...
...leider kommt man auch beim Hobby-DTP um farbige Foto nicht mehr herum. Dass DosBOX auf dem Mac nur mit 256 Farben geht ist langsam echt doof. Unter Win7-64 läuft es mit 64k Farben inzwischen sehr smooth :evil: - aber deswegen tune ich ja weiter am Igel ...mit Erfolg wie ich behaupten mööchte :rolleyes:

Gruss Thomas

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »t.hass« (30. April 2013, 22:30)


57

Mittwoch, 1. Mai 2013, 10:23

Hallo,

nur um die Diskussion hier nicht in die falsche richtung abdriften zu lassen:
..aber nicht mit JPEG, da es ja zur Anzeige dekomprimiert werden muss.
aber doch nur ein einziges Mal, und das bevor der Performancetest startet. GEOS (egal welches Programm) kann nur Bilder anzeigen, die es vorher in sein eigenes, internes Format konvertiert hat. Das Quellformat ist dann vergessen und zu Asche zerfallen. Guggst du auch hier:
http://www.geos-infobase.de/WBB_317/inde…D=4452#post4452

Später, wenn R-BASIC mit Bildern direkt umgehen kann, kann Bernd ja einen Grafik-Performance-Test nachrüsten ;-)

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

58

Freitag, 3. Mai 2013, 21:15


...habe ich entgegen zu wirken versucht, indem bei jedem Schleifendurchlauf die Bitmap zur Anzeige des Wertes neu gezeichnet wird. In wieweit das ne gute Möglichkeit zur Leistungsmessung ist, kann ich wiederum nicht sagen...
Asche über mein Haupt. Den Print-Befehl habe ich, wie ich gerade feststellen musste, zu Unrecht unterschlagen :S
Kein Problem.

Zitat

Um den Perf-Wert zu ermitteln habe ich den GEOS-Igel noch mal angeworfen, diesmal aber mit geladenem UniVBE+VBEHZ (eigentlich nur damit er 60 Hz macht und mich das TFT nicht nervt). Jetzt komme ich reproduzierbar auf 4000 vs. 3500 "Runden". Offensichtlich kitzelt UniVBE noch etwas mehr (~14%) Leistung aus der Grafikkarte und Speed's "Print" profitiert davon :thumbup:
Prima! Deine korrigierten / ergänzten Werte trage ich nach. Danke.

Ich nutze z.B. GEOS im 256-Farben Grafikmodus und da ist die Darstellung von JPGs extrem langsam...

Zitat

..leider kommt man auch beim Hobby-DTP um farbige Foto nicht mehr herum. Dass DosBOX auf dem Mac nur mit 256 Farben geht ist langsam echt doof. Unter Win7-64 läuft es mit 64k Farben inzwischen sehr smooth :evil: - aber deswegen tune ich ja weiter am Igel ...mit Erfolg wie ich behaupten mööchte :rolleyes:
So ein VIA C3 Board hätte ich fast einmal gekauft, bin dann aber wieder irgendwie davon abgekommen. 64k Farben wären mir auch lieber, mit den 256 Farben kann ich aber leben.

Dass DOSBox unter Windows gut und schnell funktionieren kann, war immer meine Vermutung, hatte aber bisher nie ne eindeutige Bestätigung dafür gehört.
Bernd

59

Montag, 13. Mai 2013, 21:40

Hallo

ich nutze Bernds Programme (nicht nur Speed) gerade um sicher zu stellen, dass meine Änderungen an R-BASIC die eigenständig lauffähigen Programme nicht inkompatibel machen. Bisher fuzzt alles ganz prima ;-)
Bei der Gelegenheit möchte ich darauf aufmerksam machen, dass man den Launcher (Das Programm, das mit Icon im Wold-Order zu sehen ist) auch an andere Orte verschieben kann, z.B. in einen Unterordner von World. Das geht immer, auch wenn der Programmierer das nicht vorgesehen hat ;-)

Vielleicht ist folgendes auch für andere interessant: Bernd schrieb auf seiner Webseite zu speed:
Die eingestellte Schrittweite ändert die Anzeige der Ergebnisse, wobei "1" den exakt ermittelten Wert zeigt , "10" ersetzt die letzte Ziffer durch eine Null, "100" ersetzt die beiden letzten Ziffern durch Nullen.
Cool wäre wenn du vorher 5 bzw. 50 addierst, dadurch wird die Anzeige gerundet.
Beispiel: Der Wert ist 768
Deine Variante liefert 760 bzw. 700
Mitt Additon gib es 768+5 = 773 -- > 770 bzw 768+50=818 --> 800

Gruß
Rainer
Es gibt 10 Arten von Menschen - die einen wissen was binär ist, die anderen nicht.

60

Dienstag, 14. Mai 2013, 11:58

Version 0.62 hochgeladen. NEU: Jetzt mit korrekter Rundung der letzten beiden Stellen. 8) http://www.geopixel.de/RBPROGS/SPEED.HTM
Rainer hat im vorherigen Posting gut beschrieben, worum und wie es geht.

Am 29.05.13 den Link geändert.
Bernd

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mütze« (29. Mai 2013, 19:58)


Zur Zeit sind neben Ihnen 2 Benutzer in diesem Thema unterwegs:

2 Besucher

Thema bewerten